Tutoriales – Como instalar VMWare Server 2.0 en Ubuntu 8.04 Hardy Heron

En este tutorial vamos a ver como se instala y configura VMWare 2.0 en Ubuntu 8.04 Hardy Heron de una forma fácil y sencilla.

Lo primero que tenemos que hacer es descargar la aplicación aquí, nos abre la página de descargas de VMWare seleccionamos Download Now bajo donde dice VMWare Server 2.0.

Luego aparece una pantalla donde colocamos nuestro usuario y password si ya estamos registrados o creamos un nuevo registro, esto es necesario para obtener el serial que nos pide durante la instalación.

Seleccionamos descargar la imagen TAR (ojo de NO seleccionar la versión RPM) a nuestro escritorio o cualquier carpeta de tu preferencia, recuerda la carpeta ya que la utilizaremos en un momento (es algo pesado aproximadamente 535 MB).

Instala las dependencias necesarias ejecutando en la consola:

sudo apt-get install linux-headers-`uname -r` build-essential xinetd

Fijate en las comillas que utilizamos son de este tipo “ si utilizas otras te dará un error.

Luego ve a la carpeta donde descargaste VMWare y ejecuta:

tar xvzf VMware-server-2.0.0-116503.i386.tar.gz

Y luego entramos al directorio descomprimido con:

cd vmware-server-distrib/

Y ejecutamos el script de instalación:

sudo ./vmware-install.pl

Durante la instalación te harán muchas preguntas, puedes elegir la opción por defecto con la tecla Entrar. Si tienes una versión anterior instalada te hará la pregunta que si quieres desinstalar esta antes de continuar puedes seleccionar que sí.

Al final de la instalación te preguntará si quieres ingresar el serial coloca que si e inserta el serial de 20 dígitos que te fue dado cuando te registraste.

Si seleccionaste todas las opciones por defecto Vmware toma como administrador a root, como Ubuntu no trae un usuario root creado por defecto (y no es bueno por razones de seguridad que sea el que maneje el servidor de Vmware) vamos a cambiar el archivo de autorización ejecutamos:

sudo gedit /etc/vmware/hostd/authorization.xml

Nota: puedes utilizar como editor a vim, nano, emacs o el de tu preferencia

Y cambiamos la línea que dice  <ACEDataUser>root</ACEDataUser> por:

<ACEDataUser>nombredetuusuario</ACEDataUser>

Cambiando nombredetuusario por el usuario que quieres que administre Vmware Server 2.0, puede ser el que utilizas por defecto en Ubuntu.

Vmware Server 2.0 no tiene ninguna aplicación de escritorio que nos permita administrar nuestras máquinas virtuales sino que se hace desde el navegador (por ejemplo Firefox), para entrar en la misma máquina donde instalamos en el servidor colocamos en el navegador https://127.0.0.1:8333/ ó http://127.0.0.1:8222/ siempre es aconsejable utilizar https.

Si estás utilizando Firefox 3.x o superior te va a dar un mensaje de advertencia que el certificado no corresponde con el sitio, esto es porque el certificado no está firmado por ninguna autoridad, haz click en Añadir una Excepción y agrega el sitio y ya podrás utilizarlo normalmente.

Si quieres entrar desde otra máquina remotamente tienes que escribir https://direccionIPdelservidor:8333 y listo.

Eso es todo, cualquier sugerencia, duda o problema dejanos un comentario.

Saludos

Olivers

Si quieren recibir más noticias del mundo del Software Libre, Código Abierto, Open Source y Linux subscríbanse a nuestro Feed de Noticias RSS aquí.

Share

olivers

Fanático del software libre, fotógrafo de fin de semana. Co-fundador de tutanda.com y ddw.cl. Me puedes seguir en Twitter @odeabreu.

También te puede gustar...

44 Respuestas

  1. Jonathan dice:

    Hola,

    Soy utilitario de VMWare desde hace bastantes años. Hace una semana me descargué el nuevo vmware server 2.0 y lo instalé en mi máquina con opensuse. Lo primero de todo, descubro que la nueva interfaz web es tremendamente más lenta que la anterior. Aparte de eso, si que parece ser que una vez que has abierto la máquina virtual parece que es más eficiente y consume menos RAM.

    Pero el problema viene que cada vez que enciendo el ordenador, los servicios de vmware están parados, y no puedo arrancar vmware. A partir de aqui dos soluciones. La primera ejecutar cada vez el vmware-config.pl y la segunda ir a los niveles de ejecucion de sus y arrancar los servicios. Ambas soluciones no son nada eficientes. ¿Sabéis cómo puedo solucionar esto? He probado muchas cosas y no consigo que los servicios estén corriendo o que se puedan arrancar cuando inicie vmware.

    Un saludo y gracias,

  2. Olivers dice:

    Hola Jonathan, has probado desinstalar por completo el vmware y volverlo a instalar?.

    La verdad es que no lo he probado en Opensuse, pero aquí puedes encontrar una guía paso a paso de cómo instalarlo en Opensuse:

    http://www.howtoforge.com/install-vmware-server-on-opensuse10.3

    Espero que te sirva cualquier duda estamos a la orden

    Saludos
    Olivers

  3. Williams dice:

    Buenas, es verdad la interfaz es muy lenta, pero en mi caso los servicios de vmware aveces se inician automáticamente y otras no, el mensaje me informaba que hay problemas con los linux-header realice nuevamente la configuración con el scrip vmware-config.pl, desinstale el vmware y actualice las dependencia y hasta los momentos ningún problema tengo instalados ubuntu 8.04.

  4. Saryon dice:

    Hola,

    Muchas gracias por el tutorial. Me ha quitado el miedo para instalar vmware en mi máquina Ubuntu 8.04

    Tengo un problema al hacer login en el VMWare Infraestructure web access porque me dice que no tengo permisos para logearme en el servidor.

    Tengo hecho lo que me dices en /etc/vmware/hostd/authorization.xml

    Muchas gracias. Salu2

  5. Olivers dice:

    Hola Saryon, prueba reiniciando el servicio de vmware ejecutando

    /etc/init.d/vmware restart

    E intentas hacer login de nuevo.

    Si no te funciona vuelve a escribir y vemos como lo podemos solucionar

    Saludos
    Olivers

  6. Saryon dice:

    Hola Olivers,

    Un millón de gracias por todo. Vmware corre perfecto.

    Salu2

  7. Wolf dice:

    hola,

    he utilizado Vmware player pero en la particion de windows ya que en mi trabajo solo usamos xp, en mi casa tengo ubuntu 8.10 intrepid y quiero usar Vmware server en el por lo que he seguido los pasos aqui descritos al poner tar xvzf VMware-server-2.0.0-122956.i386.tar.gz en la consola me dice los siguente:

    $ cd VMware-server-2.0.0-122956.i386.tar.gz
    bash: cd: VMware-server-2.0.0-122956.i386.tar.gz: No existe el fichero ó directorio

    logicamente no puedo seguir los paso que siguen, el archivo tar esta en mi escritorio, ademas de que tengo un kernel diferente 2.6.27-7-generic no sé si esto tenga algo que ver y no soy muy experto en ubuntu.

    Me podrian ayudar por favor!

    Gracias!

  8. Olivers dice:

    Hola Wolf, el comando de cd sirve para cambiar de directorios como el archivo de VMware no es un directorio pues nunca te va a ejecutar el comando.

    Si te descargaste ya el archivo por decir en la carpeta home tendrias que ir a la carpeta ejecutando cd /home y una vez ahí ejecutas el comando de tar.

    Si ya lo descomprimiste sería ejecutar cd vmware-server-distrib/ sin la parte de .tar.gz

    Espero que haya quedado claro sino vuelve a escribir y te intentaremos ayudar mejor

    Nota: Tambien lo puedes buscar por la interfaz gráfica y descomprimirlo por ahí lo que tienes que fijarte en que carpeta lo descomprimes para seguir con los demás comandos.

    Saludos
    Olivers

  9. The Final Boss dice:

    Acabo de actualizar mi kernel al 2.6.24-22 Generic y mi vmware server dejo de funcionar.

    Me manda el siguiente error:
    Falla de conexión

    Firefox no puede establecer una conexión con el servidor en 127.0.0.1:8333.
    Aunque el sitio parece válido, el navegador no puede conectarse.

    Tengo Linux Mint 5 Elyssa x64 (Basado en Ubuntu 8.04 Hardy Heron).

    Cuando corro de nuevo el programa de configuracion :

    sudo vmware-config.pl

    me sale el siguiente error.

    None of the pre-built vmmon modules for VMware Server is suitable for your
    running kernel. Do you want this program to try to build the vmmon module for
    your system

    Tambien me dice que la version del gcc que tengo es la 4.2.4, y que lo ideal seria que lo compilara con 4.2.3..
    alguna sugerencia???
    Saludos.

  10. ASI2 dice:

    Buenas:
    Tengo VMWare Server en Ubuntu, y mi problema es que no tengo red en la máquina virtual de XP mediante bridge, aunque misteriosamente le llega la configuración DHCP del router.
    No hace ping ni desde Ubuntu a Maquina Virtual ni MV a Ubuntu ni MV a router.
    Al hacer ifconfig en Ubuntu no aparece vmnet0 que supuestamente es la que hace el bridge, pero si que salen vmnet1 y vmnet8.
    Alguien sabe que pasa?
    Gracias.

    • Olivers dice:

      Hola ASI2, pueden ser muchas causas por lo que no haga el brigde, prueba primero reiniciando el servicio de VMWARE

      sudo /etc/init.d/vmware restart

      Si con esto no te funciona prueba colocar la máquina virtua con la red en modo NAT a ver si con esto te funciona solo para probar que el VMWARE se está comunicando por algún medio a la red

      Por último puedes probar ejecutando el script de setup del VMWARE, muchas veces que se actualiza la versión de Kernel se desconfigura el VMWARE ejecuta dentro de la carpeta descomprimida de VmWare

      sudo ./vmware-install.pl

      Prueba con esto y dinos como te fue

      Saludos
      Olivers

  11. David dice:

    Creo que el manual es demasiado claro, agradezco a Olivers por su tiempo, y sugiero a futuros, post que lean todo el documento para no preguntar algo que ya fue respondido.

    Tip.- pregunta si y solo si, ya no pudiste hacer nada, de no ser asi, no hay motivo para preguntar. 😉

  12. Olivers dice:

    Gracias por tu comentario David

    Hay veces que la gente cuando es novata le cuesta seguir los pasos o no estan seguros de lo que hacen por eso siempre son bienvenidas las preguntas.

    Claro que leer dos veces no hace daño, pero nunca es bueno quedarse con la duda.

    Saludos
    Olivers

  13. chusferna dice:

    Hola amigos

    tengo instalado un vmware server en ubuntu 8.04
    el problemilla es que cuando le doy a full screen se queda la pantalla en negro
    y no hay manera de volver
    agradeceria si alguien sabe lo que pudiera ser me echera una mano

    un saludo

  14. LadyK dice:

    Gracias!!!
    He leído los consejos para cambiar usuario (no me dejaba entrar, luego de cambiarlo tampoco me dejaba hasta que he reiniciado la aplicación tal y como has dicho) y se ha solucionado :)

    Ahora mi duda, ¿cómo puedo cambiar el directorio de las máquinas virtuales para que estén en el segundo disco duro?

    Gracias mil otra vez.

  15. Olivers dice:

    @chusferna Hola gracias por tu comentario y disculpa el tiempo que me tarde en responder puedes probar reiniciando el manejador de ventanas presionando al mismo tiempo CTRL+ALT+BORRAR (Backspace o como le llames) o pasando a una de las consolas TTY con CTRL+ALT+F1 (o F2 hasta F5).

    Luego puedes ver el log de tu sistema para ver cual fue el fallo.

    Una vez que veas el log escribe aquí lo que dice y veremos que podemos hacer por ti.

    @LadyK me alegro que te haya servido.

    Para cambiar el directorio lo puedes hacer de dos formas:

    1. Modificas el archivo /etc/vmware/config y buscas la línea que dice:

    vmdir = “/var/lib/vmware/Virtual Machines”

    Y la cambias por la que quieras y luego reinicias el servidor VMWare

    2. O puedes ejecutar de nuevo la configuración de VMWare con:

    sudo /usr/bin/vmware-config.pl

    Cuando te pregunte cual es el directorio donde quieres guardar tus máquinas virtuales le indicas el directorio que quieras.

    Espero que te sirva y cualquier duda vuelve a escribir

    Saludos
    Olivers

  16. LadyK dice:

    The path “[/media/discoduro2/vmware/Virtual Machines]” is a relative path. Please
    enter an absolute path.

    In which directory do you want to keep your virtual machine files?
    [/var/lib/vmware/Virtual Machines]

    No sé qué es eso de absolute path… me he dejado algo en la ruta? óò

  17. DrXtr dice:

    He leido y releido tanto el tutorial como el post y no encuentro solución.

    El problema es el siguiente, al hacer

    sudo apt-get install linux-header-`uname -r` build-essential xinetd

    me responde

    E: No se pudo encontrar el paquete linux-header-2.6.24-23-generic

    He intentado poniendo todo tipo de comillas y la respuesta es parecida, vaya por anticipado que ya tenia instalado build essential con sinaptic, por lo que he seguido para adelante pese al error. Todo funciona bien hasta llegar el momento en que me pregunta si deseo que ejecute “vmware-config.pl” respondo que si y me advierte de que estoy usando la version del gcc 4.2.4, y que lo ideal seria que lo compilara con 4.2.3. Pese a ello sigo para adelante
    Y me da un error que ya no recuerdo pero relacionado con el gcc.

    No me desanimo, desinstalo con “vmware-uninstall.pl”, le paso el “purge” por consola para asegurarme que se desinstala todo, hago lo mismo con “build-essential” y empiezo el proceso desde el principio.

    Resultado.

    E: No se pudo encontrar el paquete linux-header-2.6.24-23-generic

    Aqui me rindo y pregunto.

    Gracias anticipadas y perdonar mi torpeza e ignorancia.

    Saludos

  18. Olivers dice:

    Hola LadyK, el absolute path se refiere a la ruta al directorio donde estás montando ese dispositivo, al parecer lo estás colocando de forma correcta y no se porque no te lo acepta.

    Prueba colocando como path /dev/dispositivo_discoduro2 cambia dispositivo_discoduro2 por el nombre de tu dispositivo lo más seguro es que sea sda(numero) o hda(numero)

    Prueba esto y dinos como te fue

    Saludos
    Olivers

  19. Olivers dice:

    Hola DrXtr, al parecer estos linux headers ya no se encuentran en los repositorios, intenta descargarlo de aquí:

    https://launchpad.net/ubuntu/hardy/+package/linux-headers-2.6.24-23

    Y lo descomprimes dentro del directorio /usr/src

    Prueba con esta solución a ver si te funciona

    Lo de la advertencia que te da con gcc es normal y no hay problemas que continues la instalación así.

    Si sigues teniendo problemas vuelve a escribir

    Saludos
    Olivers

  20. DrXtr dice:

    Hola Olivers, ante todo gracias por tu rapida repuesta.

    He hecho lo que me has indicado y al descomprimir “linux_2.6.24.orig.tar.gz” en la carpeta /usr/src, me crea una carpeta “linux-2.6.24.2”, ejecuto la instrucción

    sudo apt-get install linux-header-`uname -r` build-essential xinetd

    y el resultado es el mismo.

    E: No se pudo encontrar el paquete linux-header-2.6.24-23-generic

    tambien he probado a renombrar la carpeta descomprimida a “linux-header-2.6.24-23-generic” y tampoco.

    Estoy por desistir he instalar Vmware 1.0x

    Mira a ver si se te ocurre algo.

    Saludos y gracias de nuevo.

  21. Olivers dice:

    Hola DrXtr, al descomprimir los headers en la carpeta /usr/src ya no es necesario que ejecutes la línea:

    sudo apt-get install linux-header-`uname -r`

    Solo la parte de

    sudo apt-get install build-essential xinetd

    En el momento que instales el VMWare te pregunta donde está el directorio de los headers de linux dale la ruta de /usr/src/linux-2.6.24.2 y ya con esto te debería funcionar

    Cualquier cosa vuelve a escribir

    Saludos
    Olivers

  22. DrXtr dice:

    Hola de nuevo Olivers. Ante todo gracias por tu paciencia.

    He hecho lo que me has dicho.

    Primero:

    sudo apt-get install build-essential xinetd

    Luego en la instalacion de vmware al llegar al “vmware-config.pl” y tras ignorar el aviso de de las gcc

    What is the location of the directory of C header files that match your running
    kernel? [/usr/src/linux/include] /usr/src/linux-2.6.24.2

    The path “/usr/src/linux-2.6.24.2” is an existing directory, but it does not
    contain a “linux” subdirectory as expected.

    He probado a añadir /include y este es el resultado.

    What is the location of the directory of C header files that match your running
    kernel? [/usr/src/linux/include] /usr/src/linux-2.6.24.2/include

    The path “/usr/src/linux-2.6.24.2/include” is a kernel header file directory,
    but it does not contain the file “linux/version.h” as expected. This can
    happen if the kernel has never been built, or if you have invoked the “make
    mrproper” command in your kernel directory. In any case, you may want to
    rebuild your kernel.

    Tambien he probado /include/linux

    The path “/usr/src/linux-2.6.24.2/include/linux” is an existing directory, but
    it does not contain a “linux” subdirectory as expected.

    Si que existe un directorio /include/linux pero no contiene ningun archivo “version.h”
    Hay varios archivos “version.h” pero en directorios /sound, /pcmcia, /dvb etc.

    Sigo abusando de tu paciencia.

    Saludos.

  23. DrXtr dice:

    Hola Oliver.

    Problema solucionado de momento.

    He estado trastenado y empezando de cero. He borrado y desinstalado todo linux-headers, build-essential, etc.

    He introducido

    sudo apt-get install linux-header-`uname -r` build-essential xinetd

    pero añadiendo una “s” al final de “header” es decir “headers” y sustituyendo “uname -r” por “2.6.24-23-generic”, tal que asi:

    sudo apt-get install linux-headers-2.6.24-23-generic build-essential xinetd

    y todo a funcionado durante la configuración, pero algo he debido de hacer mal durante esta, porque no se me abre la interfaz en el Firefox.

    La repito y te cuento.

    Gracias por todo.

  24. DrXtr dice:

    Hola Oliver.

    El pesao otra vez. Era un problema de configuracion de las interfaces de red.

    No te preocupes, funciona todo de cine, incluso me ha reconocido las dos maquinas que tenia con la version 1.05 una con Xp y otra con Fedora y a primera vista me resulta mas comodo y claro.

    Gracias otra vez por tu tutorial y tu paciencia.

  25. LadyK dice:

    Pues nada, lo dejé en el directorio por defecto ya que no hubo manera humana de cambiarlo. Además fui infiel con VirtualBox… Gracias por la ayuda Olivers. Sigo experimentando con los dos.

  26. er dice:

    sudo apt-get install linux-header-`uname -r` build-essential xinetd. Simplemente no funciono. Sustitui apt-get por aptitude y todo como la seda. Los header no los necesite con mi Hardy.

  27. yp dice:

    Casi al final de la instalación aparece el siguiente error:
    None of the pre-built vmmon modules for VMware Server is suitable for your
    running kernel. Do you want this program to try to build the vmmon module for
    your system (you need to have a C compiler installed on your system)? [yes]

    Using compiler “/usr/bin/gcc”. Use environment variable CC to override.

    Your kernel was built with “gcc” version “4.2.3”, while you are trying to use
    “/usr/bin/gcc” version “4.2.4”. This configuration is not recommended and
    VMware Server may crash if you’ll continue. Please try to use exactly same
    compiler as one used for building your kernel. Do you want to go with compiler
    “/usr/bin/gcc” version “4.2.4” anyway? [no]

    ¿Qué hago?

  28. Olivers dice:

    Hola yp, lo que te está advirtiendo VMWare es que la versión del compilador de C gcc es más actual de la que se usó para el Kernel, no debería darte problemas simplemente responde a esa ultima pregunta yes y continúa con la instalación

    Cualquier problema vuelve a escribir

    Saludos
    Olivers

  29. yp dice:

    Hola de nuevo. Ha compilado y funciona, lo único es que no me deja entrar con otro usuario distinto de root.
    He modificado el usuario con gedit /etc/vmware/hostd/authorization.xml, pero al intentar entrar me dice que no tengo permisos.
    Por lo demás funciona perfectamente.
    Muchas gracias.

  30. Olivers dice:

    Hola yp, prueba reiniciando el VMware Server despues de modificar el archivo:

    sudo /etc/init.d/vmware restart

    Con esto debería funcionar

    Saludos
    Olivers

  31. yp dice:

    Perfecto.
    Gracias.

  32. Olman Sandoval Obando dice:

    Estoy tratando de instalar VMWare Server 2.0 en Ubuntu 8.10 y empezando ejecuto

    [email protected]:~$ sudo apt-get install linux-header- “uname -r” build-essential xinetd
    y me desplega lo siguiente :

    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    E: No se pudo encontrar el paquete linux-header
    [email protected]:~$ …

    Que estoy haciendo mal..???

  33. Olivers dice:

    Hola Olman, el problema es que estas dejando un espacio entre linux-header- y “uname -r” deben ir todo pegado

    linux-header-“uname -r”

    Prueba a ver si con esto se arregla el problema

    Saludos
    Olivers

  34. Olman Sandoval Obando dice:

    Hola Olivers: he intentado de varias maneras ejecutar el primer comando (sudo apt-get install linux-header-`uname -r` build-essential xinetd ) cambiando las comillas, pero no ha habido forma que resulte. Estos son los mensajes que da:

    [email protected]:~$ sudo apt-get install linux-header-`uname -r` build-essential xinetd
    [sudo] password for olman:
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    E: No se pudo encontrar el paquete linux-header-2.6.28-11-generic
    [email protected]:~$ sudo apt-get install linux-header-“uname -r” build-essential xinetd
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    E: No se pudo encontrar el paquete linux-header-uname -r
    [email protected]:~$ sudo apt-get install linux-header-`uname-r` build-essential xinetd
    bash: uname-r: orden no encontrada
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    E: No se pudo encontrar el paquete linux-header
    [email protected]:~$ sudo apt-get install linux-header-“uname-r” build-essential xinetd
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    E: No se pudo encontrar el paquete linux-header-uname-r
    [email protected]:~$ sudo apt-get install linux-header-`uname -r` build-essential xinetd
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    E: No se pudo encontrar el paquete linux-header-2.6.28-11-generic
    [email protected]:~$
    . el ultimo que dice que no encontro el paquete, revise el synaptic e indica que el paquete instaldo es el : linux-header-lbm-2.6.28-11-generic version instalada 2.6.28-11.12.

    Que debo hacer????

    Actualice Ubuntu a 9.04

    Slds y muchas gracias por su ayuda.

    JESUS Y MARIA TE BENDICEN HOY Y SIEMPRE

    OLMAN SANDOVAL

  35. Olivers dice:

    Hola Olman, había un pequeño error en el tutorial en vez de header es headers con una s al final, prueba ahora con esta corrección a ver si te funciona

    Saludos
    Olivers

  36. Olman Sandoval Obando dice:

    Buenas noches Oliver.

    Ya di el primer paso. Realice lo que me indicaste y produjo esto :

    [email protected]:~$ sudo apt-get install linux-headers-`uname -r` build-essential xinetd
    [sudo] password for olman:
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    linux-headers-2.6.28-11-generic ya está en su versión más reciente.
    build-essential ya está en su versión más reciente.
    xinetd ya está en su versión más reciente.
    Se instalaron de forma automática los siguientes paquetes y ya no son necesarios.
    libboost-iostreams1.34.1 p7zip libsoup2.2-8
    Utilice «apt-get autoremove» para eliminarlos.
    0 actualizados, 0 se instalarán, 0 para eliminar y 16 no actualizados.
    [email protected]:~$ tar xvzf VMware-server-2.0.0-116503.i386.tar.gz
    tar: VMware-server-2.0.0-116503.i386.tar.gz: No se puede open: No existe el fichero ó directorio
    tar: El error no es recuperable: salida ahora
    tar: Child returned status 2
    tar: Salida con error demorada desde errores anteriores
    [email protected]:~$ tar xvzf VMware-server-2.0.0-122956.i386.tar.gz
    tar: VMware-server-2.0.0-122956.i386.tar.gz: No se puede open: No existe el fichero ó directorio
    tar: El error no es recuperable: salida ahora
    tar: Child returned status 2
    tar: Salida con error demorada desde errores anteriores
    [email protected]:~$

    Espero tu guia?

    Gracias por tu ayuda, Es invaluable. Con personas asi, novatos como yo vamos aprendiendo poco a poco. Razon t ienes cuando dices que algunos no somos rapidos en entender y mas aun tratandose de informatica.

    JESUS Y MARIA TE BENDICEN HOY Y SIEMPRE

    SLDS
    Olman Sandoval

  37. Jose Vasaquez dice:

    He editado el archivo sudo gedit /etc/vmware/hostd/authorization.xml, par poder cambiar el administrador. Pero nada, Incluso he puesto el root y nada.
    Tambien luego de editar el archivo he reiniciado VMware con sudo /etc/init.d/vmware restart
    Y aun asi no puedo hacer el login.
    Ayuda,,

  38. generalillo dice:

    Hola!

    Felicidades por la guia

    Yo he seguido todo tal como indicas pero al final, cuando pongo la direccion en el navegador me aparece la pagina en blanco, he reiniciado el servicio pero sigue sin aparecerme nada.
    Haber si me puedes echar una mano. Por cierto,tengo ubuntu 9.04

  39. generalillo dice:

    Hola!
    Gracias por contestar tan rapido, finalmente pude solucionar el problema simplemente reiniciando el equipo.
    Cuando creo una maquina virtual nueva, al querer cambiar la ubicacion donde voy a guardar el disco duro o cuando quiero elegir el directorio donde tengo mi imagen ISO se me queda continuamente “loading” y no hace nada. No se si es porque al darle a todo por defecto en la instalacion del vmware ahora no me deja seleccionar otra unidad que no sea mi disco duro

  40. Diego-Diaz dice:

    Buenas, Muchachos estoy interesado en iniciarme en lo de las maquinas virtuales, intento instalarla en mi ubuntu 8.10 tal y cual como se describe en el tutorial pero en la parte donde donde realiza la serie de preguntas, y ya finalizando me salen una serie de errores que no he podido comprender, Agradesco si alguno ya ha tenido que solucionar estos, aqui muestro los errores que me salen.

    make: se ingresa al directorio `/tmp/vmware-config1/vmmon-only’
    make -C /lib/modules/2.6.27-14-generic/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
    make[1]: se ingresa al directorio `/usr/src/linux-headers-2.6.27-14-generic’
    CC [M] /tmp/vmware-config1/vmmon-only/linux/driver.o
    En el archivo incluído de /tmp/vmware-config1/vmmon-only/./include/machine.h:24,
    from /tmp/vmware-config1/vmmon-only/linux/driver.h:15,
    from /tmp/vmware-config1/vmmon-only/linux/driver.c:49:
    /tmp/vmware-config1/vmmon-only/./include/x86.h:830:1: aviso: se redefinió “PTE_PFN_MASK”
    En el archivo incluído de include/asm/paravirt.h:7,
    from include/asm/irqflags.h:55,
    from include/linux/irqflags.h:57,
    from include/asm/system.h:11,
    from include/asm/processor.h:17,
    from include/linux/prefetch.h:14,
    from include/linux/list.h:6,
    from include/linux/module.h:9,
    from /tmp/vmware-config1/vmmon-only/linux/driver.c:12:
    include/asm/page.h:22:1: aviso: esta es la ubicación de la definición previa
    En el archivo incluído de /tmp/vmware-config1/vmmon-only/linux/vmhost.h:13,
    from /tmp/vmware-config1/vmmon-only/linux/driver.c:71:
    /tmp/vmware-config1/vmmon-only/./include/compat_semaphore.h:5:27: error: asm/semaphore.h: No existe el fichero ó directorio
    /tmp/vmware-config1/vmmon-only/linux/driver.c:146: error: se especificó el campo desconocido ‘nopage’ en el inicializador
    /tmp/vmware-config1/vmmon-only/linux/driver.c:147: aviso: inicialización desde un tipo de puntero incompatible
    /tmp/vmware-config1/vmmon-only/linux/driver.c:150: error: se especificó el campo desconocido ‘nopage’ en el inicializador
    /tmp/vmware-config1/vmmon-only/linux/driver.c:151: aviso: inicialización desde un tipo de puntero incompatible
    /tmp/vmware-config1/vmmon-only/linux/driver.c: En la función ‘LinuxDriver_Ioctl’:
    /tmp/vmware-config1/vmmon-only/linux/driver.c:1670: error: demasiados argumentos para la función ‘smp_call_function’
    make[2]: *** [/tmp/vmware-config1/vmmon-only/linux/driver.o] Error 1
    make[1]: *** [_module_/tmp/vmware-config1/vmmon-only] Error 2
    make[1]: se sale del directorio `/usr/src/linux-headers-2.6.27-14-generic’
    make: *** [vmmon.ko] Error 2
    make: se sale del directorio `/tmp/vmware-config1/vmmon-only’
    Unable to build the vmmon module.

    For more information on how to troubleshoot module-related problems, please
    visit our Web site at “http://www.vmware.com/download/modules/modules.html” and
    “http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html”.

    Execution aborted.

    [email protected]:/home/usuario/Escritorio/vmware-server-distrib# sudo gedit /etc/vmware/hostd/authorization.xml

    (gedit:8882): Gtk-WARNING **: cannot open display:
    [email protected]:/home/usuario/Escritorio/vmware-server-distrib#

    De antemano agradesco la ayuda que me puedan brindar ya que no tengo mucho tiempo de estar con ubuntu.

  41. Nano dice:

    Hola, te explico mi problema he instalado todo correctamente pero en el momento de logearme en la web me da el failure …

    tambn realice el /etc/init.d/vmware restart
    y me pone esto:
    Stopping VMware autostart virtual machines:
    Virtual machines done
    Stopping VMware management services:
    VMware Virtual Infrastructure Web Access
    VMware Server Host Agent done
    Stopping VMware services:
    VMware Authentication Daemon failed
    VM communication interface socket family: failed
    Virtual machine communication interface failed
    Virtual machine monitor failed
    Bridged networking on /dev/vmnet0 done
    Host network detection done
    DHCP server on /dev/vmnet1 failed
    Host-only networking on /dev/vmnet1 failed
    DHCP server on /dev/vmnet8 failed
    NAT service on /dev/vmnet8 done
    Host-only networking on /dev/vmnet8 failed
    Virtual ethernet failed

    luego trato de logearme denuevo en
    https://127.0.0.1:8333/
    con el nombre de usuario q designe en
    sudo gedit /etc/vmware/hostd/authorization.xml
    y la clave q uso para iniciar secion en mi pc
    pero me sige tirando el error
    no se que podria ser porfavor ayudenme
    se los agradescode antemano
    saludos

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *